aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2023-10-12 22:29:59 -0400
committerRalph Amissah <ralph.amissah@gmail.com>2023-10-12 23:17:30 -0400
commit4573e88c2f9b5f8c57c6b2e0f4c0526bb729526e (patch)
treec2795a8449e68b987aa194ed7197989ea7511cb7 /shell.nix
parentnix packages, added graphicsmagick (diff)
nix flake shell ruby-3.2 update
Diffstat (limited to 'shell.nix')
-rwxr-xr-xshell.nix18
1 files changed, 10 insertions, 8 deletions
diff --git a/shell.nix b/shell.nix
index 27fadf87..aa2fb632 100755
--- a/shell.nix
+++ b/shell.nix
@@ -3,10 +3,10 @@
with pkgs;
mkShell {
buildInputs = [
- ruby_3_1
- rubyPackages_3_1.rake
- rubyPackages_3_1.sqlite3
- rubyPackages_3_1.thor
+ ruby_3_2
+ rubyPackages_3_2.rake
+ rubyPackages_3_2.sqlite3
+ rubyPackages_3_2.thor
sqlite
graphicsmagick
unzip
@@ -16,14 +16,16 @@ mkShell {
#texlive-combined-full
nixFlakes
validatePkgConfig
+ nix-output-monitor
+ nix-tree
jq
git
#starship
];
shellHook = ''
- if [[ -e ".envrc" ]]; then
- source .envrc
- fi
- eval "$(starship init bash)"
+ #if [[ -e ".envrc" ]]; then
+ # source .envrc
+ #fi
+ #eval "$(starship init bash)"
'';
}