aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2023-10-14 12:27:50 -0400
committerRalph Amissah <ralph.amissah@gmail.com>2023-10-19 12:22:09 -0400
commit254371aa83682d52cac1746eaf1892538d97f352 (patch)
tree0edae59137e5e1db520a4b2b76a523957ae22c9c /shell.nix
parenttexpdf address issue with texlive-2023 (diff)
updates nix flake & ruby 3.3, nix direnv 2.4.0
Diffstat (limited to 'shell.nix')
-rwxr-xr-xshell.nix57
1 files changed, 27 insertions, 30 deletions
diff --git a/shell.nix b/shell.nix
index aa2fb632..ec794cda 100755
--- a/shell.nix
+++ b/shell.nix
@@ -1,31 +1,28 @@
-#!/usr/bin/env -S nix-shell --pure
-{ pkgs ? import <nixpkgs> {} }:
+#!/usr/bin/env -S nix-shell --impure
+#!nix-shell -i bash
+{pkgs ? import <nixpkgs> {}}:
with pkgs;
-mkShell {
- buildInputs = [
- ruby_3_2
- rubyPackages_3_2.rake
- rubyPackages_3_2.sqlite3
- rubyPackages_3_2.thor
- sqlite
- graphicsmagick
- unzip
- xz
- zip
- openssl
- #texlive-combined-full
- nixFlakes
- validatePkgConfig
- nix-output-monitor
- nix-tree
- jq
- git
- #starship
- ];
- shellHook = ''
- #if [[ -e ".envrc" ]]; then
- # source .envrc
- #fi
- #eval "$(starship init bash)"
- '';
-}
+ mkShell {
+ buildInputs = [
+ ruby_3_3
+ rubyPackages_3_3.rake
+ rubyPackages_3_3.sqlite3
+ rubyPackages_3_3.thor
+ sqlite
+ graphicsmagick
+ unzip
+ xz
+ zip
+ openssl
+ #texlive-combined-full
+ nixFlakes
+ validatePkgConfig
+ nix-output-monitor
+ nix-tree
+ jq
+ git
+ #starship
+ ];
+ shellHook = ''
+ '';
+ }