aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v6/manifest.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2014-05-12 23:23:10 -0400
committerRalph Amissah <ralph@amissah.com>2014-05-12 23:23:10 -0400
commit54c4f8c8e4a952ea48a0c9969ff333eb7a514dcf (patch)
tree82facf3c312f7147e3a162cd2743c00f9d3061f7 /lib/sisu/v6/manifest.rb
parentdebian/changelog (5.3.4-1) (diff)
parentdocumentation, notes, update (diff)
Merge tag 'sisu_5.3.5' into debian/sid
SiSU 5.3.5
Diffstat (limited to 'lib/sisu/v6/manifest.rb')
-rw-r--r--lib/sisu/v6/manifest.rb14
1 files changed, 10 insertions, 4 deletions
diff --git a/lib/sisu/v6/manifest.rb b/lib/sisu/v6/manifest.rb
index 1d6bc6a9..27b90eda 100644
--- a/lib/sisu/v6/manifest.rb
+++ b/lib/sisu/v6/manifest.rb
@@ -123,7 +123,7 @@ module SiSU_Manifest
? './image'
: %{#{@f.path_rel_links.html_scroll_2}_sisu/image_sys}
@base_path=@f.output_path.manifest.dir
- @@dg ||=SiSU_Env::InfoEnv.new.digest.type
+ @@dg ||=SiSU_Env::InfoEnv.new(md.fns,md).digest(md.opt).type
@dg=@@dg
l=SiSU_Env::StandardiseLanguage.new(md.opt.lng).language
@language=l[:n]
@@ -165,9 +165,15 @@ module SiSU_Manifest
end
def summarize_sources(id,file,pth,rel,url)
sys=SiSU_Env::SystemCall.new
- dgst=(@dg =~/^sha(?:2|256)$/) \
- ? sys.sha256("#{pth}/#{file}")
- : sys.md5("#{pth}/#{file}")
+ dgst=case @dg
+ when :sha512
+ sys.sha512("#{pth}/#{file}")
+ when :sha256
+ sys.sha256("#{pth}/#{file}")
+ when :md5
+ sys.md5("#{pth}/#{file}")
+ else
+ end
if (@md.opt.act[:verbose][:set]==:on \
|| @md.opt.act[:verbose_plus][:set]==:on \
|| @md.opt.act[:maintenance][:set]==:on)