aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3/qrcode.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2011-09-24 08:16:45 -0400
committerRalph Amissah <ralph@amissah.com>2011-09-24 08:16:45 -0400
commit57bf3bd0c20140501abfef9567bd51eeac0a428c (patch)
treeb830d6c6a44ed81c8f1973d33ee571421e29fd6a /lib/sisu/v3/qrcode.rb
parentdebian/changelog (3.0.18-1) (diff)
parentv3: remote, src & sisupod processing, and rsync placement (diff)
Merge commit 'sisu-3.0.19' into debian/sid
Diffstat (limited to 'lib/sisu/v3/qrcode.rb')
-rw-r--r--lib/sisu/v3/qrcode.rb6
1 files changed, 3 insertions, 3 deletions
diff --git a/lib/sisu/v3/qrcode.rb b/lib/sisu/v3/qrcode.rb
index e244231e..1b741a48 100644
--- a/lib/sisu/v3/qrcode.rb
+++ b/lib/sisu/v3/qrcode.rb
@@ -110,7 +110,7 @@ module SiSU_QRcode
@language=l[:n]
@translate=SiSU_Translate::Source.new(@md,@language)
@brace_url=SiSU_Viz::Skin.new.url_decoration
- @dest="#{@env.path.webserv}/#{@env.path.stub_pwd}/_sisu/image"
+ @f.make_path(@f.output_path.qrcode.dir)
end
def output_metadata
fn=@f.base_filename.manifest_txt
@@ -128,7 +128,7 @@ module SiSU_QRcode
#system(%{
# cat #{pt}/#{fn} | qrencode -s 3 -o qrcm.autonomy_markup0.png
#})
- cmd=SiSU_Env::System_call.new(mn,"#{@dest}/qrc_md.#{fn}.png",@md.opt.cmd)
+ cmd=SiSU_Env::System_call.new(mn,@f.place_file.qrcode_md.dir,@md.opt.cmd)
cmd.qrencode
#system(%{
# echo "#{mn}" | qrencode -s 3 -o #{@dest}/qrc_md.#{fn}.png
@@ -140,7 +140,7 @@ module SiSU_QRcode
@manifest[:txt_title].each do |x|
mn += x
end
- cmd=SiSU_Env::System_call.new(mn,"#{@dest}/qrc_title.#{fn}.png",@md.opt.cmd)
+ cmd=SiSU_Env::System_call.new(mn,@f.place_file.qrcode_title.dir,@md.opt.cmd)
cmd.qrencode
#system(%{
# echo "#{mn}" | qrencode -s 3 -o #{@dest}/qrc_title.#{fn}.png