aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v2/param.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2011-09-24 08:16:45 -0400
committerRalph Amissah <ralph@amissah.com>2011-09-24 08:16:45 -0400
commit57bf3bd0c20140501abfef9567bd51eeac0a428c (patch)
treeb830d6c6a44ed81c8f1973d33ee571421e29fd6a /lib/sisu/v2/param.rb
parentdebian/changelog (3.0.18-1) (diff)
parentv3: remote, src & sisupod processing, and rsync placement (diff)
Merge commit 'sisu-3.0.19' into debian/sid
Diffstat (limited to 'lib/sisu/v2/param.rb')
-rw-r--r--lib/sisu/v2/param.rb12
1 files changed, 6 insertions, 6 deletions
diff --git a/lib/sisu/v2/param.rb b/lib/sisu/v2/param.rb
index 656490d9..60663830 100644
--- a/lib/sisu/v2/param.rb
+++ b/lib/sisu/v2/param.rb
@@ -120,9 +120,9 @@ module SiSU_Param
def all
s=nil
if @author
- s ||=((@date =~/([12][890]\d{2})/ ) \
- ? ("Copyright (C) #{$1} #{@author}") \
- : ('Copyright (C)' + @author)) #matches years 1800 through 20\d\d 2004w19
+ s ||=((@date =~/((?:1[4-9]|2[01])\d{2})/ ) \
+ ? ("Copyright (C) #{$1} #{@author}")
+ : ('Copyright (C)' + @author)) #matches years 1400 through 21\d\d
end
s
end
@@ -133,9 +133,9 @@ module SiSU_Param
def all
s=nil
if @author
- s ||=((@date =~/([12][890]\d{2})/ ) \
- ? ("Copyright (C) #{$1} #{@author}") \
- : ('Copyright (C)' + @author)) #matches years 1800 through 20\d\d 2004w19
+ s ||=((@date =~/((?:1[4-9]|2[01])\d{2})/ ) \
+ ? ("Copyright (C) #{$1} #{@author}")
+ : ('Copyright (C)' + @author)) #matches years 1400 through 21\d\d
end
s
end