aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v2/param.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2011-05-05 22:11:58 -0400
committerRalph Amissah <ralph@amissah.com>2011-05-05 22:11:58 -0400
commita9642d67f69d83d3fdb56ab115ef3c10bcd1895c (patch)
tree352c633d6b60a54a9ef74ff143162ac07c981b18 /lib/sisu/v2/param.rb
parentdebian/changelog (3.0.7-1) (diff)
parentv3: i18n, sysenv, class variable to prevent unnecessary re-construction of hash (diff)
Merge branch 'upstream' into debian/sid
Diffstat (limited to 'lib/sisu/v2/param.rb')
-rw-r--r--lib/sisu/v2/param.rb2
1 files changed, 2 insertions, 0 deletions
diff --git a/lib/sisu/v2/param.rb b/lib/sisu/v2/param.rb
index c500c282..656490d9 100644
--- a/lib/sisu/v2/param.rb
+++ b/lib/sisu/v2/param.rb
@@ -733,12 +733,14 @@ module SiSU_Param
end
if manpage['name']
manpage['name']=manpage['name'].join("\n.br\n")
+ manpage['name'].gsub!(/(-)/m,"\\\\\\1")
manpage['name'].gsub!(/\A/,"\n.br\n.SH NAME\n.br\n")
else
manpage['name']='man page "name/whatis" information not provided, set in header @man: name=[whatis information]'
end
if manpage['synopsis']
manpage['synopsis']=manpage['synopsis'].join("\n\n.br\n")
+ manpage['synopsis'].gsub!(/(-)/m,"\\\\\\1")
manpage['synopsis'].gsub!(/\A/,"\n.br\n.SH SYNOPSIS\n.br\n")
else
manpage['synopsis']=''